Problems with Ligthroom 5.4

Home Forums Photography Q&A Problems with Ligthroom 5.4

Viewing 15 posts - 1 through 15 (of 27 total)
  • Author
    Posts
  • #24128
    Frazer Family
    Participant

    I’ve been having trouble with my photos lately. At first I thought it was my camera card, but after some experimentation, I think it may be Lightroom. Immediately upon importing, my photos look OK, but after a few seconds, some of them turn out like photo 1. As long as I remain in the Library module, they continue to look like that, however, if I go to the Develop module and move around a bit (either switching photos or editing something) they become like photo 2. Very puzzling! My brother suggested that the problem might be that my catalogue was getting to big and bogging things down or getting bugs in it. (I had 122 GB of photos in it.) Is that likely?

    Also, if that’s the case, I’ll want to switch catalogues at some logical point – probably the beginning of 2017. Is there a way of moving photos from one catalogue to another so that I don’t have to redo all my edits from the beginning of the year?

    Attachments:
    #24132
    Ezra Morley
    Moderator

    Do you have catalog backups? (I just remembered that I haven’t backed up very recently, so I went and did it while I’m thinking about it. ๐Ÿ™ )

    A mere 122 GB of pictures shouldn’t bog down a catalog unless you have an under-powered machine… I have 6,000-7,000 (15-25MB each) photos in my catalog, and I’ve never seen anything like you’re seeing. There are lots and lots of people who have catalogs with over 100,000 photos, so the # of photos on its own shouldn’t be an issue.

    It looks to me like the embedded jpg preview inside the RAW files might be getting corrupted somehow. When you edit a photo, it creates a new preview, and the problem goes away.

    I would definitely make a backup of the current catalog, then create a new test catalog, and see if the problem persists. If it does, you know it’s not a catalog problem… If it doesn’t, well it doesn’t really prove anything 100%, but I would guess that your catalog might be getting corrupted somehow.

    If it’s true that the catalog is your problem, then you’ll definitely want to start a new one right away, so you don’t risk further damaging the old one. After you’ve found out whether your old catalog is to blame or not, you can go back, and try to repair the old one.

    I would try deleting the preview cache, and see if that solves the problem. (Be aware that Lightroom will have to re-render all the previews next time you open it, which could take a while for 120 GB worth of photos…) http://www.lightroomfanatic.com/tutorials/advanced/why-and-how-to-clear-your-lightroom-cache/

    Let us know how it goes, whether you find a solution or not!

    #24134
    Frazer Family
    Participant

    Yes, my backups are up to date: they’re done automatically every time the computer is on. I really have to think the catalogue is at fault because mine is the only one that has this problem. I tried importing my photos into another family member’s catalogue and everything worked just fine.

    Yikes! I hope I haven’t made anything worse by working with it today. It has several times given me an error message at the top of a picture saying “There was an error working with this photo,” though whatever the error is, it doesn’t seem to do much most of the time. And today on one photo it said something like, “This photo was suddenly missing” and I couldn’t do anything with the photo. I could see it and click on it, but when in the Develop module, all the options for developing were greyed out. Presets didn’t work, keyboard commands didn’t work, etc. I finally deleted the photo from the disk and re-imported. After that it worked fine.

    I’ll try deleting the preview cache and let you know how it works once it’s regenerated everything. (At least I went and deleted all my rejected photos from last year so my catalogue is now down to only 94 GB! ๐Ÿ™‚ ) Thanks so much for your help!
    ———————————————————
    Well… while I was typing this, I had Lightroom working. It still has the same problem and it always seems to be with the same photos. ๐Ÿ™ Would it be a good idea to create a new catalogue and export the photos from the old one to the new one?

    #24135
    Ezra Morley
    Moderator

    Just to be clear, I’m talking about a Lightroom catalog backup, not just a computer backup.

    You might want to run a disk check on your system, that’s almost beginning to sound like your hard drive might be having issues.

    http://www.chriswrites.com/how-to-health-check-your-macs-hard-disk/
    (Just beware of software like “CleanMyMac”, I am very wary of that sort of thing for good reason; I’ve seen all sorts of messed up computers with similar software.)

    Either that, or you just might have some corrupted RAW files on your hands. This is rather mysterious, I would definitely test with a new catalog on your own system, to rule out catalog corruption.

    Keep us posted, I’ll be very interested to know what the results are. ๐Ÿ™‚

    #24153
    Frazer Family
    Participant

    Just to be clear, Iโ€™m talking about a Lightroom catalog backup, not just a computer backup.

    Yes, the computer backs up everything onto an external HD, LR catalogues too.

    Jonathan wondered about the HD, but the rest of the computer is working just fine, including the other LR catalogues. Corrupted RAW files seem unlikely too because the same photos work just fine in another catalogue. He also wondered about the graphics card, but one would expect to have similar problems in another catalogue and we don’t (at least as far as I know).

    So I’m going try creating new catalogue. How do I get all my photos from the original one into the new one? (Preferably without losing all my edits and hopefully without transferring over the error that is causing problems! ๐Ÿ™‚ )

    Oh, and just a side question, can I rename a catalogue from Finder without messing anything up?

    #24163
    Ezra Morley
    Moderator

    How long have you noticed this issue going on? Is there a specific batch of photos that are affected, or does it span several different photo-shoots? Do you still have the RAW files on your SD card, or have you already cleared them off?

    Theoretically, you’ll still have all of your old edits/data still intact in your old catalog, so you don’t need to worry about losing everything. I wouldn’t add all the old photos to a new catalog just yet though, first let it work with just a few of your latest photos, then you can start adding your old ones in once you’re sure the problem has gone away. (As long as you don’t move any of the original RAW files, you can always go back and open up your old catalog in Lightroom, and it should be just as you left it.)

    If you rename your current catalog in Finder, Lightroom will lose track of it. For all Lightroom knows, you deleted it. ๐Ÿ™‚ You can always tell Lightroom where to find it again though, by doing File > Open Catalog. Just make sure Lightroom isn’t running when you mess with the catalog!

    You say you think the HDD isn’t the problem: here’s a question for you. How full is your computer HDD? Is it getting close to full? You should always have 15-20% of your HDD free for performance reasons. If your HDD is getting full, you’re going to have to empty it somehow. If you have all of your 122 GB worth of photos on the computer hard drive, I would suggest moving older photos to an external drive to free up some space.

    I was just reading Lightroom’s Help pages, and what do you know? Scroll down on this page till you get to “Delete the Lightroom Previews Cache” https://helpx.adobe.com/lightroom/kb/optimize-performance-lightroom.html

    Delete the Lightroom previews cache

    Although it’s rare, sometimes one or more of the following issues can occur, and if they do, you may need to delete your preview cache file:

    Your hard disk gets unexpectedly full.
    You get an error about your cache in Lightroom.
    You get artifactsโ€”such as lines, dots, or unexpected colored areasโ€”in your images.

    The file that contains your thumbnail and preview data is called [Catalogname] Previews.lrdata, and is in the same folder as your catalog.

    Your thumbnails, small previews, and 1:1 (full size) previews are kept in this Previews.lrdata file. Lightroom’s preferences have the option of when to delete the largest previews, the 1:1 previews. When you delete the 1:1 previews, the size of the Previews.lrdata file is reduced. If you don’t delete 1:1 previews, the previews file can get very large.

    Note: Do not confuse the Previews.lrdata file discussed in this technote with the [Catalogname] Smart Previews.lrdata file, which contains all your Smart Previews. In cases where there is very limited hard disk space, you may need to delete this file, but if your hard disk space is low enough that you get low hard disk errors, you should empty your trash, archive some files, and/or reorganize your data so there’s more open hard disk space.

    If you delete the Previews.lrdata file, previews are recreated for each folder or collection you open in Lightroom, so the first time you work in a folder, you’ll experience some delay while previews are recreated.

    If your images display with artifacts, such as colored lines, colored dots, or areas of unexpected colors, then your preview file may be corrupted, and the only way to fix this is to delete the previews.lrdata file.

    Note that if you included previews of images in your catalog from images that you’ve archived, you’ll lose these previews as well.

    If deleting the Previews.lrdata file does not solve your issue, try purging your Camera Raw cache file.

    In Lightroom, choose Edit > Preferences > File Handling (Windows) or Lightroom > Preferences > File Handling (Mac OS).
    Click Purge Cache under the Camera Raw Cache Settings.

    You can also change the location of this cache by clicking Choose. Note that this cache is used only by the Develop module.

    So here’s what I would do:

    • Backup your current (old) LR catalog. (..Edit > Catalog Settings > “Backup catalog when Lightroom next exits”
    • Exit Lightroom, and let it run the backup. (Note, when you make the backup, uncheck the “Check for integrity” and “Optimize the catalog” options.)
    • Re-open LR, and optimize the catalog. (..File > Optimize Catalog..)
    • Now close Lightroom and delete your preview cache following the instructions linked to above.
    • Now open Lightroom, and go take a vacation while it renders all your previews again. (Make sure your computer is cooling properly, or it’ll probably overheat). ๐Ÿ™

    If that doesn’t solve the problem, I’ll be very surprised.

    #24164
    Frazer Family
    Participant

    OK. I’ve run a few more experiments. I really hoped that I could keep working with my current LR catalogue just to get done a few photo jobs I have going right now, but when I imported the photos I just took, they nearly all looked like my first photo. ๐Ÿ™ So, I created a temporary new catalogue just so I could get the jobs done. However, though most of the photos imported normally, one of the ones I needed gave me the โ€œThere was an error working with this photoโ€ message and when I tried to develop anyway it said, “An unexpected end-of-file occurred.”

    Then a thought came to me: what if it is the card reader at fault? We once had a card reader corrupt an entire SD card. So, I switched to the wire and imported all my “problem” photos again. They came in perfectly! Yeah! ๐Ÿ™‚ I hope I’ve stumbled across the solution! Time will tell, I guess.

    Thanks for all your help and suggestions, @buddingphotographer!

    Has anyone else had such trouble with card readers?

    #24165
    Ezra Morley
    Moderator

    Ah ha! So the corrupted RAW file idea wasn’t so far off after all! ๐Ÿ™‚ Glad you found a solution, and hope that it sticks!

    I have seen an instance where a relative of mine moved several hundred .jpg pictures from an SD card to a laptop HDD, then to an external HDD and in the process about 75% of them were corrupted. They had pink/green lines and tints all over them, a real mess! We were very disappointed, and tried to diagnose the problem, but there wasn’t really any evidence to work with. Some time later, I just happened to be looking through this person’s Recycle Bin, and happened to find a folder full of the original photos that weren’t corrupted! Evidently what happened, was that the photos came off the card OK, and became corrupted when transferred to the external HDD. The originals were then unsuspectingly deleted, since they were “all safe” on the external hard drive… ๐Ÿ™‚ Thankfully, I could restore them with the click of a mouse button, and all was well!

    So learn a lesson, NEVER EVER delete your original files until you’re sure that the copies are safe and intact. Also learn that occasionally USB connections are susceptible to damage, and strange things might result, so if in doubt, try a different connection.

    #24170
    James Staddon
    Keymaster

    Just make sure Lightroom isnโ€™t running when you mess with the catalog!

    Very true! It’s fine to rename the catalog. Just shut down Lightroom before doing so AND be sure to rename the Previews folder accordingly. (There should be no “.lrcat.lock” or “lrcat-journal” files present when you rename the catalog.)

    For example, if your previous Lightroom catalog was called “Jimmys Photos”, then the Previews folder would be called “Jimmys Photos Previews.lrdata”, and if you wanted to rename the catalog to “Jimmys Portfolio”, then you would also want to rename the Previews folder to “Jimmys Portfolio Previews.lrdatea”.

    #24171
    James Staddon
    Keymaster

    Has anyone else had such trouble with card readers?

    Yes! I had a card reader go bad a few months ago. My problem was that I would plug in the card and the computer wouldn’t recognize it. I thought it was because the card had corrupted, but I knew that wasn’t the case because the pictures on the card were still viewable on the camera. I used a different card reader, and sure enough! the computer recognized it and I was able to import them no problem.

    Needless to say, I threw away the old card reader. ๐Ÿ™‚

    And that reminds me! I should buy another backup reader. Thanks for the reminder. ๐Ÿ™‚

    #24182
    Frazer Family
    Participant

    Oh, bother. I just tried importing my “problem” photos back into my original catalogue using the wire instead of the card reader… And I still have those pink and green streaks. I guess I’m back to square one… ๐Ÿ™

    How long have you noticed this issue going on? Is there a specific batch of photos that are affected, or does it span several different photo-shoots?

    I don’t remember when the first instance was – not very long ago, though. It hasn’t been one specific batch of photos, but it seems rather random. Most of the photos from Monday’s download had problems, the ones from yesterday came through perfectly, today’s are having problems again.

    Do you still have the RAW files on your SD card, or have you already cleared them off?

    I NEVER format my SD card unless everything is running well and stored in at least two other places. So, yes, they’re still on there.

    How full is your computer HDD? Is it getting close to full?

    We wondered about that too, but it’s only 1/2 full.

    So now I’ll try @buddingphotographer’s suggestions from noon and I’ll post an update when I get back from my vacation! I think the computer is cooling properly. ๐Ÿ™‚

    Thanks again for your suggestions!

    #24193
    Frazer Family
    Participant

    Well, I think things are finally running smoothly again! (Though I guess I’ll only know for sure after a few more photo shoots.) I followed your instructions, @buddingphotographer, and backed up my catalogue the way you said, optimised LR, shut down the program, deleted the preview cache, reopened LR, and went on vacation (well, not quite – I just went out to see how our new ram was faring). But that didn’t fix it, so I went on to the next step and purged the Camera Raw cache file. That seems to have corrected the problem! I was able to reimport my “problem” files with no difficulty.

    Thank you so much for you help! I was getting rather worried that my card was corrupted or something else irreparable. Thanks!

    #24194
    Ezra Morley
    Moderator

    Sure thing! Hopefully this fix stays now! ๐Ÿ™‚

    #24214
    James Staddon
    Keymaster

    Thanks for the update, @frazer-family. Do keep us posted if the issue returns.

    #24364
    Frazer Family
    Participant

    So far, so good. I’ve done several downloads now since applying ยญ@buddingphotographer’s suggestions and everything is turning out great. What a relief! I’m grateful for the help I’ve received through the forums here!

    Attachments:
Viewing 15 posts - 1 through 15 (of 27 total)

You must be logged in to reply to this topic.

Would you like to participate?

Create an Account!

Pin It on Pinterest